using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^( *)(""(?:[^""]|\\"")+"": )?(\[(?:\s+\d+,)*\s+\d+\s+\])";
string input = @"{
""foo"": ""bar"",
""oneLine"": [
1,
2,
3
],
""another\""Line"": [
1,
2,
3
],
""multipleLines"": [
{
""name"": ""X"",
""alsoOneLine"": [
4,
5,
6
],
""inner"": [
[
1,
2,
3
],
[
4,
5,
6
]
]
},
{
""name"": ""Y""
}
]
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}