use strict;
my $str = '{
"foo": "bar",
"oneLine": [
1,
2,
3
],
"another\\"Line": [
1,
2,
3
],
"multipleLines": [
{
"name": "X",
"alsoOneLine": [
4,
5,
6
],
"inner": [
[
1,
2,
3
],
[
4,
5,
6
]
]
},
{
"name": "Y"
}
]
}';
my $regex = qr/^( *)("(?:[^"]|\\")+": )?(\[(?:\s+\d+,)*\s+\d+\s+\])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}