import Foundation
let pattern = #"^( *)("(?:[^"]|\\")+": )?(\[(?:\s+\d+,)*\s+\d+\s+\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"foo": "bar",
"oneLine": [
1,
2,
3
],
"another\"Line": [
1,
2,
3
],
"multipleLines": [
{
"name": "X",
"alsoOneLine": [
4,
5,
6
],
"inner": [
[
1,
2,
3
],
[
4,
5,
6
]
]
},
{
"name": "Y"
}
]
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)