// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^( *)("(?:[^"]|\\")+": )?(\[(?:\s+\d+,)*\s+\d+\s+\])"#).unwrap();
let string = "{
\"foo\": \"bar\",
\"oneLine\": [
1,
2,
3
],
\"another\\\"Line\": [
1,
2,
3
],
\"multipleLines\": [
{
\"name\": \"X\",
\"alsoOneLine\": [
4,
5,
6
],
\"inner\": [
[
1,
2,
3
],
[
4,
5,
6
]
]
},
{
\"name\": \"Y\"
}
]
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}