re = /^( *)("(?:[^"]|\\")+": )?(\[(?:\s+\d+,)*\s+\d+\s+\])/m
str = '{
"foo": "bar",
"oneLine": [
1,
2,
3
],
"another\\"Line": [
1,
2,
3
],
"multipleLines": [
{
"name": "X",
"alsoOneLine": [
4,
5,
6
],
"inner": [
[
1,
2,
3
],
[
4,
5,
6
]
]
},
{
"name": "Y"
}
]
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end