const regex = new RegExp('(?:-|role:)??\\binfo-ansible(?=[\\s,])', 'mg')
const str = `- { role: info-ansible, }
- { role: info-ansible
- info-ansible
- info-ansibleasdasd
- info-ansible-
- info-ansibleasd
- { role: info-ansible, db_type: "emg db", hosts_dns: "{{ env_db_emg_hosts_file_dns }}", activate_server_ip: "{{ shared_db_passive_emg_server_ip }}" }
- { role: loadbalancer-remove-node, pool_host_port: '{{ env_db_port }}', pool_host_name: "{{ common_db_active_emg_server }}", pool_name: '{{ env_loadbalancer_vservers.active_emg_db.pool.pool_name }}' }
,role: info-ansible
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}