# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:-|role:)??\binfo-ansible(?=[\s,])"
test_str = ("- { role: info-ansible, }\n"
"- { role: info-ansible\n"
"- info-ansible\n\n"
"- info-ansibleasdasd\n\n\n"
"- info-ansible-\n"
"- info-ansibleasd\n\n"
"- { role: info-ansible, db_type: \"emg db\", hosts_dns: \"{{ env_db_emg_hosts_file_dns }}\", activate_server_ip: \"{{ shared_db_passive_emg_server_ip }}\" }\n"
"- { role: loadbalancer-remove-node, pool_host_port: '{{ env_db_port }}', pool_host_name: \"{{ common_db_active_emg_server }}\", pool_name: '{{ env_loadbalancer_vservers.active_emg_db.pool.pool_name }}' }\n\n"
",role: info-ansible\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.