re = /(?:-|role:)??\binfo-ansible(?=[\s,])/m
str = '- { role: info-ansible, }
- { role: info-ansible
- info-ansible
- info-ansibleasdasd
- info-ansible-
- info-ansibleasd
- { role: info-ansible, db_type: "emg db", hosts_dns: "{{ env_db_emg_hosts_file_dns }}", activate_server_ip: "{{ shared_db_passive_emg_server_ip }}" }
- { role: loadbalancer-remove-node, pool_host_port: \'{{ env_db_port }}\', pool_host_name: "{{ common_db_active_emg_server }}", pool_name: \'{{ env_loadbalancer_vservers.active_emg_db.pool.pool_name }}\' }
,role: info-ansible
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end