use strict;
my $str = '- { role: info-ansible, }
- { role: info-ansible
- info-ansible
- info-ansibleasdasd
- info-ansible-
- info-ansibleasd
- { role: info-ansible, db_type: "emg db", hosts_dns: "{{ env_db_emg_hosts_file_dns }}", activate_server_ip: "{{ shared_db_passive_emg_server_ip }}" }
- { role: loadbalancer-remove-node, pool_host_port: \'{{ env_db_port }}\', pool_host_name: "{{ common_db_active_emg_server }}", pool_name: \'{{ env_loadbalancer_vservers.active_emg_db.pool.pool_name }}\' }
,role: info-ansible
';
my $regex = qr/(?:-|role:)??\binfo-ansible(?=[\s,])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}