import Foundation
let pattern = #"(?:-|role:)??\binfo-ansible(?=[\s,])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
- { role: info-ansible, }
- { role: info-ansible
- info-ansible
- info-ansibleasdasd
- info-ansible-
- info-ansibleasd
- { role: info-ansible, db_type: "emg db", hosts_dns: "{{ env_db_emg_hosts_file_dns }}", activate_server_ip: "{{ shared_db_passive_emg_server_ip }}" }
- { role: loadbalancer-remove-node, pool_host_port: '{{ env_db_port }}', pool_host_name: "{{ common_db_active_emg_server }}", pool_name: '{{ env_loadbalancer_vservers.active_emg_db.pool.pool_name }}' }
,role: info-ansible
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)