using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)(?=(?:\d\d\d)+(?!\d))";
string substitution = @".";
string input = @"158841054854
2022
602300000000000000000000
1298615
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}