re = /(?<=\d)(?=(?:\d\d\d)+(?!\d))/m
str = '158841054854
2022
602300000000000000000000
1298615
'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result