import re
regex = re.compile(r"(?<=\d)(?=(?:\d\d\d)+(?!\d))", flags=re.MULTILINE)
test_str = ("158841054854\n"
"2022\n"
"602300000000000000000000\n"
"1298615\n")
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)