$re = '/(?<=\d)(?=(?:\d\d\d)+(?!\d))/m';
$str = '158841054854
2022
602300000000000000000000
1298615
';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;