using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.)\1*\.+(?:\1+\.*)*";
string substitution = @"$1";
string input = @"我我....我...我.要...要要...要学....学学..学.编..编编.编.程.程.程..程..一闪一闪亮晶晶,满天都是小星星";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}