use strict;
my $str = '我我....我...我.要...要要...要学....学学..学.编..编编.编.程.程.程..程..一闪一闪亮晶晶,满天都是小星星';
my $regex = qr/(.)\1*\.+(?:\1+\.*)*/mip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";