const regex = /(.)\1*\.+(?:\1+\.*)*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.)\\1*\\.+(?:\\1+\\.*)*', 'gmi')
const str = `我我....我...我.要...要要...要学....学学..学.编..编编.编.程.程.程..程..一闪一闪亮晶晶,满天都是小星星`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);