import Foundation
let pattern = #"(.)\1*\.+(?:\1+\.*)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"我我....我...我.要...要要...要学....学学..学.编..编编.编.程.程.程..程..一闪一闪亮晶晶,满天都是小星星"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)