$re = '/(.)\1*\.+(?:\1+\.*)*/mi';
$str = '我我....我...我.要...要要...要学....学学..学.编..编编.编.程.程.程..程..一闪一闪亮晶晶,满天都是小星星';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;