#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z]{1}(\s)"
Local $sString = "E.g Mark S Twain==> S to be replaced as string.empty and result to be “Mark Twain”" & @CRLF & _
"" & @CRLF & _
"J Mark Tailor ==> Again J to be replaced as string.empty and result to be “Mark Tailor”"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")