using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]{1}(\s)";
string input = @"E.g Mark S Twain==> S to be replaced as string.empty and result to be “Mark Twain”
J Mark Tailor ==> Again J to be replaced as string.empty and result to be “Mark Tailor”";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}