package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{1}(\s)`)
var str = `E.g Mark S Twain==> S to be replaced as string.empty and result to be “Mark Twain”
J Mark Tailor ==> Again J to be replaced as string.empty and result to be “Mark Tailor”`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}