$re = '/[A-Z]{1}(\s)/m';
$str = 'E.g Mark S Twain==> S to be replaced as string.empty and result to be “Mark Twain”
J Mark Tailor ==> Again J to be replaced as string.empty and result to be “Mark Tailor”';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);