$re = '/(?<!¬¦@#~)(Kathryn Kuhlman|Max KANTCHEDE)/m';
$str = 'Meet God\\\'s General Kathryn Kuhlman. <br>
<img class="lazy_responsive" title="¬¦@#~Kathryn Kuhlman - iUseFaith.com" src="https://www.iusefaith.com/ojm_thumbnail/1000/32f808f79011a7c0bd1ffefc1365c856.jpg" alt="¬¦@#~Kathryn Kuhlman - iUseFaith.com" width="1600" height="517" />
<br>
Follow <a href="https://www.iusefaith.com/en-354" title="¬¦@#~Kathryn Kuhlman">¬¦@#~Kathryn Kuhlman</a>
<br>
Max KANTCHEDE
<a href = "blah blah blah ¬¦@#~Kathryn Kuhlman"/>¬¦@#~Kathryn Kuhlman</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);