import re
regex = re.compile(r"(?<!¬¦@#~)(Kathryn Kuhlman|Max KANTCHEDE)", flags=re.MULTILINE)
test_str = ("Meet God\\'s General Kathryn Kuhlman. <br>\n"
"<img class=\"lazy_responsive\" title=\"¬¦@#~Kathryn Kuhlman - iUseFaith.com\" src=\"https://www.iusefaith.com/ojm_thumbnail/1000/32f808f79011a7c0bd1ffefc1365c856.jpg\" alt=\"¬¦@#~Kathryn Kuhlman - iUseFaith.com\" width=\"1600\" height=\"517\" />\n"
"<br>\n"
"Follow <a href=\"https://www.iusefaith.com/en-354\" title=\"¬¦@#~Kathryn Kuhlman\">¬¦@#~Kathryn Kuhlman</a>\n"
"<br>\n"
"Max KANTCHEDE\n"
"<a href = \"blah blah blah ¬¦@#~Kathryn Kuhlman\"/>¬¦@#~Kathryn Kuhlman</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")