using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^202[0-9]\b.*Forecast\.xlsm$";
string input = @"2020.01.01 W1 Forecast.xlsm
2021.01.01 W1 Forecast.xlsm";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}