re = /^202[0-9]\b.*Forecast\.xlsm$/m
str = '2020.01.01 W1 Forecast.xlsm
2021.01.01 W1 Forecast.xlsm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end