$re = '/^202[0-9]\b.*Forecast\.xlsm$/m';
$str = '2020.01.01 W1 Forecast.xlsm
2021.01.01 W1 Forecast.xlsm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);