// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^202[0-9]\b.*Forecast\.xlsm$").unwrap();
let string = "2020.01.01 W1 Forecast.xlsm
2021.01.01 W1 Forecast.xlsm";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}