const regex = new RegExp('^202[0-9]\\b.*Forecast\\.xlsm$', 'gm')
const str = `2020.01.01 W1 Forecast.xlsm
2021.01.01 W1 Forecast.xlsm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}