#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).+? (.+) \((\d+) points?\)\nWhen input is\n(.*?)\nStandard output (.+?)\n(.+)\nEdit\nClone\nRemove"
Local $sString = ""1. Compare output (2 points)" & @CRLF & _
"When input is" & @CRLF & _
"xxxtoyxxx" & @CRLF & _
"Standard output exactly matches" & @CRLF & _
"Midfix: toy" & @CRLF & _
"" & @CRLF & _
"Edit" & @CRLF & _
"Clone" & @CRLF & _
"Remove"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")