$re = '/.+? (.+) \((\d+) points?\)\nWhen input is\n(.*?)\nStandard output (.+?)\n(.+)\nEdit\nClone\nRemove/s';
$str = '"1. Compare output (2 points)
When input is
xxxtoyxxx
Standard output exactly matches
Midfix: toy
Edit
Clone
Remove';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);