import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+? (.+) \\((\\d+) points?\\)\\nWhen input is\\n(.*?)\\nStandard output (.+?)\\n(.+)\\nEdit\\nClone\\nRemove";
final String string = "\"1. Compare output (2 points)\n"
+ "When input is\n"
+ "xxxtoyxxx\n"
+ "Standard output exactly matches\n"
+ "Midfix: toy\n\n"
+ "Edit\n"
+ "Clone\n"
+ "Remove";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}