use strict;
my $str = '"1. Compare output (2 points)
When input is
xxxtoyxxx
Standard output exactly matches
Midfix: toy
Edit
Clone
Remove';
my $regex = qr/.+? (.+) \((\d+) points?\)\nWhen input is\n(.*?)\nStandard output (.+?)\n(.+)\nEdit\nClone\nRemove/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}