re = /.+? (.+) \((\d+) points?\)\nWhen input is\n(.*?)\nStandard output (.+?)\n(.+)\nEdit\nClone\nRemove/
str = '"1. Compare output (2 points)
When input is
xxxtoyxxx
Standard output exactly matches
Midfix: toy
Edit
Clone
Remove'
# Print the match result
str.match(re) do |match|
puts match.to_s
end