# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)=.*?\Krobot/Android/gmi;t' <<< "For example:
preview_download_robot=View your beautiful Robot!
I would like to replace the word \"Robot\" with \"Android\", but only after the = symbol. It should apply to any variation of the word \"Robot\" (e.g., Robot, robot, Robot-ally, Robot., Robothelp, etc.), regardless of capitalization or punctuation. The replacement should occur without breaking the document structure. "