import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)=.*?\\Krobot";
final String string = "For example:\n"
+ "preview_download_robot=View your beautiful Robot!\n\n"
+ "I would like to replace the word \"Robot\" with \"Android\", but only after the = symbol. It should apply to any variation of the word \"Robot\" (e.g., Robot, robot, Robot-ally, Robot., Robothelp, etc.), regardless of capitalization or punctuation. The replacement should occur without breaking the document structure. ";
final String subst = "Android";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}