const regex = /(?i)=.*?\Krobot/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)=.*?\\Krobot', 'gmi')
const str = `For example:
preview_download_robot=View your beautiful Robot!
I would like to replace the word "Robot" with "Android", but only after the = symbol. It should apply to any variation of the word "Robot" (e.g., Robot, robot, Robot-ally, Robot., Robothelp, etc.), regardless of capitalization or punctuation. The replacement should occur without breaking the document structure. `;
const subst = `Android`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);