using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)=.*?\Krobot";
string substitution = @"Android";
string input = @"For example:
preview_download_robot=View your beautiful Robot!
I would like to replace the word ""Robot"" with ""Android"", but only after the = symbol. It should apply to any variation of the word ""Robot"" (e.g., Robot, robot, Robot-ally, Robot., Robothelp, etc.), regardless of capitalization or punctuation. The replacement should occur without breaking the document structure. ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}