import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[,\"\\n]|\"[^\"]*\"),){2}\\K\".*?\",?(,\".*?\",)";
final String string = "\"Test\",\"test\",\"test1234\",\"\",\"\"\n"
+ "\"Test\",\"test\",\"test1234\",\"url_test.com/test\",\"\"\n"
+ "\"Test\",\"test\",\"test1234\",\"\",\"testing\"\n"
+ "\"Test\",\"test\",\"test12\"34\",\"\",\"\"\n"
+ "\"Test\",\"test\",\"te\\\"st1234\",\"\",\"\"\n"
+ "\"Test\",\"test\",\"test1\"2,34\",\"\",\"\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}