import Foundation
let pattern = #"^(?:(?:[,"\n]|"[^"]*"),){2}\K".*?",?(,".*?",)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"Test","test","test1234","",""
"Test","test","test1234","url_test.com/test",""
"Test","test","test1234","","testing"
"Test","test","test12"34","",""
"Test","test","te\"st1234","",""
"Test","test","test1"2,34","",""
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)