use strict;
my $str = '"Test","test","test1234","",""
"Test","test","test1234","url_test.com/test",""
"Test","test","test1234","","testing"
"Test","test","test12"34","",""
"Test","test","te\\"st1234","",""
"Test","test","test1"2,34","",""';
my $regex = qr/^(?:(?:[,"\n]|"[^"]*"),){2}\K".*?",?(,".*?",)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}