using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""cn=([A-Z]{4}),.*(\|cn=([A-Z0-9]{4}),.*)""";
string input = @"""cn=AAAA,ou=Profils,o=SF|cn=BBBB,ou=Profils,o=SF""
""cn=CCCC,ou=Profils,o=SF""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}