re = /"cn=([A-Z]{4}),.*(\|cn=([A-Z0-9]{4}),.*)"/m
str = '"cn=AAAA,ou=Profils,o=SF|cn=BBBB,ou=Profils,o=SF"
"cn=CCCC,ou=Profils,o=SF"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end