const regex = /"cn=([A-Z]{4}),.*(\|cn=([A-Z0-9]{4}),.*)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"cn=([A-Z]{4}),.*(\\|cn=([A-Z0-9]{4}),.*)"', 'gm')
const str = `"cn=AAAA,ou=Profils,o=SF|cn=BBBB,ou=Profils,o=SF"
"cn=CCCC,ou=Profils,o=SF"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}