package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"cn=([A-Z]{4}),.*(\|cn=([A-Z0-9]{4}),.*)"`)
var str = `"cn=AAAA,ou=Profils,o=SF|cn=BBBB,ou=Profils,o=SF"
"cn=CCCC,ou=Profils,o=SF"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}