import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"cn=([A-Z]{4}),.*(\\|cn=([A-Z0-9]{4}),.*)\"";
final String string = "\"cn=AAAA,ou=Profils,o=SF|cn=BBBB,ou=Profils,o=SF\"\n"
+ "\"cn=CCCC,ou=Profils,o=SF\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}