using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"message:\s(?<METADATA_ERROR>[^\\\n]+)";
string input = @"message: org.springframework.jdbc.UncategorizedSQLException: CallableStatementCallback; uncategorized SQLException for SQL <{call XYZ_API.PROCESS_EVENT(?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)}>; SQL state <16000>; error code <20011>; ORA-00060: deadlock detected while waiting for resource\nORA-06512: at ""ABC_OWNER.XYZ_API"", line 5133\nORA-06512: at ""ABC_OWNER.XYZ_API"", line 2001\nORA-06512: at ""ABC_OWNER.XYZ_API"", line 6829\nORA-06512: at line 1\n; nested exception is java.sql.SQLException: ORA-00060: deadlock detected while waiting for resource\nORA-06512: at ""ABC_OWNER.XYZ_API"", line 5133\nORA-06512: at ""ABC_OWNER.XYZ_API"", line 2001\nORA-06512: at ""ABC_OWNER.XYZ_API"", line 6829\nORA-06512: at line 1\n'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}