import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "message:\\s(?<METADATA_ERROR>[^\\\\\\n]+)";
final String string = "message: org.springframework.jdbc.UncategorizedSQLException: CallableStatementCallback; uncategorized SQLException for SQL <{call XYZ_API.PROCESS_EVENT(?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)}>; SQL state <16000>; error code <20011>; ORA-00060: deadlock detected while waiting for resource\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 5133\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 2001\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 6829\\nORA-06512: at line 1\\n; nested exception is java.sql.SQLException: ORA-00060: deadlock detected while waiting for resource\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 5133\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 2001\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 6829\\nORA-06512: at line 1\\n'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}