# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"message:\s(?<METADATA_ERROR>[^\\\n]+)"
test_str = "message: org.springframework.jdbc.UncategorizedSQLException: CallableStatementCallback; uncategorized SQLException for SQL <{call XYZ_API.PROCESS_EVENT(?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)}>; SQL state <16000>; error code <20011>; ORA-00060: deadlock detected while waiting for resource\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 5133\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 2001\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 6829\\nORA-06512: at line 1\\n; nested exception is java.sql.SQLException: ORA-00060: deadlock detected while waiting for resource\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 5133\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 2001\\nORA-06512: at \"ABC_OWNER.XYZ_API\", line 6829\\nORA-06512: at line 1\\n'"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.